HomeHomePublicPublic3rd Party Modul...3rd Party Modul...Dynamic Forms-CAPTCHA Code Not WorkingDynamic Forms-CAPTCHA Code Not Working
New Post
4/15/2014 5:17 AM

Hi Aderson

We haven’t “talked” in a while.  I hope all is well with your and yours.  I have been keeping up with your articles/videos on DNN Hero though.  YOU ROCK!  Thank you for all that you do with DNN. 

Aderson, I am having a very rough time with DataSprings Dynamic Forms 4.1 in DNN 5.6.1 with getting captcha to work on a new form that I’ve just created.  I have other forms on the site that use captcha and they work just fine.  I’ve tried everything that I know to get this thing to work.  I’ve been struggling with this for about a week now and this part of the website will be launched in a couple of weeks and I really don’t want to put out something that is not complete and functioning properly.  I did e-mail DataSprings, but I thought about you (actually, I thought about you first)…Here is the site: 

I've tried deleting the module and adding it back in, I've deleted the page several times and added it back in (after removing the page/modules from the Recycle Bin), I've copied a module that works from another form and placed it on my page and that doesn't work either.  I've printed out the module settings from a form that currently works and compared it to the settings on the form that is not working and I don't see anything different.  I have both client and server side validation turned on under the General Settings (also on the all of the other forms on the site).  I've tuned on/off all of the settings with various combinations to see if I can get this to work.  I have two fields (telephone and summary) that are not required field (and I do have other forms on the site that are set up similarly).  I am totally stumped.  I ended up making the captcha field a non-required field in order to get the form to submit, but that is not right. 

I am very frustrated at this point and cannot come up with a viable answer.  I don’t know if maybe there was an update to this module and the some functionality no longer works or if a Windows 7 update made something stop functioning.  It just seems really weird that all of the previously built forms work, but any new ones don’t.  I’ve also tried created a form in my test environment using the same parms that are on the other forms on the site, but NOTHING works.  I've look at a couple of blogs, but they have not helped either and I’ve looked at the documentation from the DataSprings site and the help text on the module; neither have helped me figure this out. 

When you get a chance and if it is not an imposition, would you mind looking at the attached pdf file of the form settings?  Maybe I’m missing something and maybe you can lend some insight as to what I may be doing incorrectly in establishing this form?  I will tell you that when we first got this module I think it was installed with DNN 4.9 and we’ve since upgraded to 5.6.1.  (I wish we could afford to upgrade to current version of DNN). 

You do know if it is one of those stupid check boxes, I’m going to feel really ashamed… :)

 Thank you so much for reading my e-mail and for your precious time!

 Very respectfully yours,

 Ingrid Z. Anderson, City of Livonia, MI

 P.S. You know the spell check tried to change your name to “Anderson”… :)

New Post
4/15/2014 6:16 AM
Hi Ingrid,

Great job! You didn't let the spell checker mess it up! :)

Yes long time! Great that you have been checking - We put a lot of effort there.

In regards to the problem you are facing, that is a hard one. All settings seem to be just fine. My guess at this point is that there is some other content on the site that might be interfering with the form.

If you say that the form works on other ages but not this one I would do the following:

1 - Hide all modules from that page (via Module Permissions);
2 - See if it works;
3 - If it does, then you know there is one of the modules messing things up on that page and now you can find whihc one is it;
4 - If it still doesn't, then change the skin to a default dnn skin;
5 - If that works, then you know the problem is within the skin;
6 - If it still doesn't then maybe it is the page name (god knows why :) - So try to rename it;
7 - If it still doesn't work, I would start to eliminate each filed on the form until the form will submit fine.

Lot of work I know, but I don't see a way around that to troubleshoot this. I like to troubleshoot by elimination like this.

Best of luck!

New Post
4/16/2014 5:58 AM

Hi Aderson- I thought that I would let you know that I got an e-mail from DataSprings.  Here is their response:

Hi Ingrid:

At first glance I don’t see any specific reasons why it would not work however this version of Dynamic Forms is extremely old (probably 5 or 6 years old) and is no longer a supported release of the module. You would need to upgrade to the latest version of the 5.x release full support, and also because I think there are conflicts with new browsers and this version of our module with AJAX and jQuery etc…  If you need to keep that version of DNN you might want to still purchase the 5.x release and we can get you the latest release of Dynamic Forms that does work on your version of DNN until you later upgrade DNN.

Long story short; we're looking to upgrade the module to version 5.  Hopefully that will resolve this issue with the creation of any new forms (and hopefully not mess up the ones that are already in place- you know how that goes...). :D

Thank you again so very much for your time in looking at this for me ADERSON! :D

Keep up the GREAT work with DNNHero!

Ingrid Anderson



New Post
4/16/2014 7:29 AM

Thank you for letting us know Ingrid!

I hope you get it upgraded and running correctly at some point.

Keep us posted please.



New Post
4/17/2014 7:56 AM


I just wanted to let you know that my supervisor contacted the company that hosts our site and their developers turned on Advanced Captcha.  Here is the message:


This issue has been resolved.

The DNN captcha does not work with dynamic forms. It displays but doesn’t validate properly.

I updated your system so you can use the advanced data springs captcha and configured this form to use that. I also updated so the field was required.

I tested and was unable to submit until the valid code was entered.

If you have other dynamic forms using a captcha, please let us know and we can make sure they are correct.


I just wanted to let you know and thank you again for all of your suggestions.  It appears that now when I create any new forms, I will have to use Advanced Captcha until we go up on a newer version of DNN.  It does save use a few $'s in the budget. 

You and your family have a safe and wonderful holiday (should you celebrate Easter).

I'll always check new material.



P.S.  PLEASE include this testimonial:  Aderson (, is the BEST!  The videos, forums, and information given about DNN are very intuitive and helpful.  I always check before going anywhere else.  YOU GUYS ROCK!!!! :D

~Ingrid Z. Anderson, City of Livonia, MI


HomeHomePublicPublic3rd Party Modul...3rd Party Modul...Dynamic Forms-CAPTCHA Code Not WorkingDynamic Forms-CAPTCHA Code Not Working

30 days money back guaranteed